Bug Reports and Feedback for Snapmakerjs V2.5.X


#96

The installation process has changed and if you want assistance then go to https://uaetechnician.ae/samsung-service-centre to resolve the problem regarding snapmakerjs.


#97

Downloaded the 2.5.4 version for Windows 64 bit today, when uploading pictures for laser engraving the size of the picture was almost double what it was when uploaded into the 2.5.1 version, also preview quality was nearly twice as grainy in appearance. When G-Code was generated and uploaded to the workspace the graphic displayed looked like a very skewed barcode. Uninstalled 2.5.4 version and reverted back t the 2.5.1 version.


#98

I experienced the same issue…rather annoyed because I had them dialed in pretty good.

Please add that same feature that’s in Snapmaker3D that allows you to export your profile so we can make backups of our custom settings?


#99

link to tutorial https://snapmaker.zendesk.com/hc/en-us/articles/360013696613-What-should-I-do-if-the-first-layer-does-not-stick-to-the-heated-bed- and watch setings in video https://www.youtube.com/watch?v=EnINVgu7F0I


#100

Snapmakerjs 2.5.4 32bit only lists Workspace, Laser G-code Generator, and CNC G-code Generator. Nothing for 3D printing.


#101

Yes. 3D printing part for Windows 32bit builds is no longer supported from 2.5.3, checkout the changelog here: Downloads and Updates.


#102

WHAT? :flushed::scream:

Could you please clarify that. Snapmaker is primarily a 3D Printer and now you’re saying that the current software no longer supports 3 D printing !?

Surely what you mean is that the latest updates have simply not addressed 3D Printing issues.

Can we assume that the next updarte will?


#103

Oh sorry I mean just for Windows 32bit builds 3D slicing is deprecated :rofl: @BriHar Haha pls checkout our latest beta version Snapmakerjs v2.5.5 Beta Testing we are optimizing the user experience using 3D part.


#104

I got a very strange bug: While printing something via USB, I tried to generate the gcode for the next part, but it always showed “Slicing 0,0%” in the bottom left corner. Reloading the part didn’t help. After the print finished I tried it with restarting SnapmakerJS, but it was still the same. I had to restart my PC to get SnapmakerJS to slice a part again.

It felt like the Cura engine in the background got stuck and blocked the slicing (I tried to find the process in the task manager but couldn’t find it)

OS: Win10 x64
SnapmakerJS v2.5.5 Beta 1


#105

Do you know if the outline feature has been fixed yet, it still does not work in the v2.5.4.
Even with simple vectors like circle or teardrop lines.
Have been running the cnc to cut files, they work in the on path mode but make two passes for the lines.
An issue with the Cnc is the set screw does not stay tight and the bit drops out , should go with different motor and chuck or replacement option would be good.
ron


#106

@SchnabsiX
Must be the slice engine got stuck, it can’t deal with large model files (like 120M or 150M depends on your PC). 0% denotes that it’s still preparing and parsing the model file (exported from workspace) while not actually starts slicing.

@ronnelson8 The outline feature has been broken for many vectors. It’s based on algorithm called Martinez, while we’re using a 3rd party library to deal with the part (well we’ve fixed some of its issues), but it’s not working well still. We may have some time to read the papers and re-implement the algorithm in one or two months, but a lot of features (some for the Snapmaker 2.0) are ahead of us :roll_eyes:

“make two passes for the lines”, sometimes for the vectors converted from other formats, they look like they have one path but actually two paths overlapped in the SVG file. Another issue I can’t help much, not yet considering the original one, but we have huge upgrades in Snapmaker 2.0.


#107

Bug report: The software is adding a skin to a hole at the bottom that is not in the model. I tried different settings (e.g. bottom to 0.0) but it still genereates the code

.


#108

In Win 10, the 3d-printing quality setting profile is located in:
C:\Users\stanl\AppData\Local\Programs\snapmakerjs\resources\app\CuraEngine\Config
The “stanl” above is my user name, just ignore it.
You can copy custom profiles from or to this folder.


#109

Rather use the following path - its universal regardless of the username:

%LocalAppData%\Programs\Snapmakerjs\resources\app\CuraEngine\Config

Be sure to include the % characters or it wont work :wink:


#110

Snapmakerjs 2.5.4, win 64-bit. I can’t update any of the parameters when I select “Customize” under “Print Settings”. I can see all the parameters, but when I move the mouse over any of them, I get a red “NOT” sign (circle with a slash).

What do I need to do to modify these parameters?


#111

Did you duplicate default settings? There is a little button on the right side to duplicate existed official settings.


#112

I did not, and that fixed my issue. Thank-you!


#113

When I create a Text Object, I cannot use the keyboard arrow keys (left right up down) to move the text object.

Doug


#114

I have noticed that when selecting a slower first level (I use 10mm) that it only applies to the print and not the add on’s (Brim, Raft, etc.) I tried to make a print with Brim and the outer section of the Brim worked great but it printed at full speed and not the selected speed for first layer. Is this a bug or as expected?


#115

Hi! You have to set the speed setting for the brim manually in the config file. you need to change the “default_value” of the parameter “skirt_brim_speed”. I use 15mm/s

My post about the config file.