Bug Reports and Feedback for Snapmakerjs V2.5.X


#1

If you find a bug in Snapmakerjs V2.5.X, please report it here. Our developer @parachvte will solve it as soon as possible. Thank you!


Downloads and Updates
Downloads and Updates
Downloads and Updates
Downloads and Updates
Downloads and Updates
#2

Using V2.5 will now not let me generate a lot of my designs for 3d print G-code Had to go back a version
no problem there (its on Win 10 64bit machine) I tried the 32bit version same thing.


#3

Experiencing scaling issues when bringing sketchup files into snapmakerjs. 1 foot 6 inch turns into 18 mm. Need to add a unit selection option (MM or Inch) when importing 3d files for printing.


#4

Hi, what software and export file format did you use for your designs? Could you please send one of the files that cannot work in Snapmakerjs V2.5?


#5

Just a question. I haven’t received my Snapmaker enclosure yet (should arrive in a week or so) but from what I can gather from the documentation online, I can see no signal link of any sort between the enclosure and the controller. so how exaclty does the “Door Detection” work? - How does the software know what state the door is in?
I assumed this would automatically turn the laser off when the door was opened and resume once shut again - or am I amiss?


#6

There is a cable connected between the enclosure and controller (remember the reserved port on controller? it’s reserved for extensions).


#7

Then can I assume this cable will be included with the Enclosure, and the included documentation supplemented with the connection details?


#8

Yes. The documentation will update on our website as well in 2 weeks.


#9

with 2.5 I cannot generate the GCode for 3d print files. The “Generate GCode” button stays unavailable, I get a “forbidden”(?) Symbol when I move the mouse over it. Same file, same Settings work fine with 2.4.5.
Any ideas?


#10

From what I can tell, the Generate G-code button is disabled when one of 3 conditions is met:

  1. No model at workspace
  2. Slicing
  3. The model(s) oversteps the build plate

Looks like you are not case 1) and 3), so you are currently slicing. You pressed the Generate G-code button once but it didn’t finished. Maybe it’s because your model way too large to be handled by the slice engine? Or you can toggle the developer console to see if anything went wrong which makes Snapmakerjs stop working.


#11

According to the Quick Start Guides a cautionary note is shown (e.g. 3-in-1 3D Printer Quick Start Guide Page 13) "Do NOT connect or disconnect the cables or USB when the machine is powered on. I can understand about the cables, but USB is supposed to be Plug and Play.

In the Manual (Generate G-code Using Snapmakerjs & Generate G-code Using Snapmaker 3D) no such caution is given when instructing the user to insert the USB Drive - unplugging the cable to the computer would in this case also be a given.

Is there in fact any danger plugging and unplugging USB on the Snapmaker without powering down?


#12

The model is the one you see on the screenshot. Nothing special, from this Thingiverse here: https://www.thingiverse.com/thing:2832864 (I also tried with others).
Same model in Snapmakerjs 245 is working fine, I can generate the GCode from that.
Can you explain “toggle te developer console”? Thanks!


#13

The answer is no, you can plug/unplug the USB or cables anytime as long as the machine is not working. We wrote that was intended to avoid any unexpected behavior from users. (One special case I can tell is that if you unplug and re-plug the tool head cable, the controller may not detect the tool head correctly. But restart will bring it back to work, not damage is given to the machine)

We have corrected the typo in our new multi-language manuals (“or USB” is deleted already), probably you received our old manual :smiley: Still thanks for your correction.


#14

Toggle the developer console: “View” on Menu bar -> Toggle Developer Tools -> Console. It’s like the console on Chrome. You can see more details on the console.

With v2.5.0 on Mac (Mojave 10.14.1) I can generate G-code as the figure above.


#15

Thanks for the info. Just a heads up though, the links to the Quick Start Guides on the download page of the web site still all refer to the old manuals :wink:


#16

I can’t see anything wrong in the Developer Console. What do you want me to search for?
(I have a Windows PC btw, no Mac so can’t repro on Mojave 10.14.1 :slight_smile: )


#17

snapmakerjs V2.5.0. Ubuntu 16.04

Generate G-code button is unavailable. It sliced correct twice and isn’t working since then (restarted software and computer, but nothing worked).


#18

@e-maddin @dskerr Thanks for reporting.

We’ve found what the bug is: If the initial size of model exceed the size of plate, the G-code Generate button will be disabled :disappointed_relieved::disappointed_relieved:. We will fix it in the next version (in 2 weeks), if you don’t need the laser preview feature in v2.5.0, v2.4.6 should work for you.


#19

I am having a heck of a time with the laser part of snapmakerjs.

I have imported an SVG to vector cut a box and snapmakerjs automatically enlarges the SVG to the max work volume (125mm) instead of leaving the original dimensions. I manually change the dimensions and the picture disappears in the preview and doesn’t come back until I upload the SVG again.

Jake


#20

Two bugs noticed:

  1. About that greyed out g-code generate button, if your original model exceeds print area, it will stay grayed out even if you downscale model. Workaround is to export model after downscaling, close snapmakerjs, open it again and import downscaled model. Now slicing will work.

  2. There is no way to control support material printing speed. I tried to adjust printing speeds for night printing, but there is no option to adjust this one. It prints supports so fast that it makes terrible noise even if other speeds are slower. That should definitely be adjustable just like other printing speeds.