Bug Reports and Feedback for Snapmakerjs V2.4.X

I use V2.4.1
When I press the play error, the printer moves around, but laser is not activated.

greetings to all
I just downloaded the latest evolution 2.41.
Congratulations for the work done. I must have missed something important, I don’t see how to integrate a STL file in 3D printing mode!
I am on Linux Opensuse Tumbleweed


someone might give me the procedure … thank you

You’re missing a tab in the left sidebar. You should be seeing what looks like a wireframe cube, which is the 3D printing tab. See this image I grabbed from one of the posts above. I don’t know why it’s not showing up for you. You might try uninstalling, rebooting, and then reinstalling.

@philuser
Ahhh, the 3DP tab for Linux is hidden cuz we didn’t tested Linux yet :frowning: Forgot to mention this on the release note since Snapmaker3D also supported only for macOS and Windows, but we are adding Linux support in the future release.

@parachvte
Thank you for your great responsiveness. So I’m really looking forward to your Linux patch.
However why not release in “open source” the snapmakerjs code, this immediately allows you to benefit from all the fabulous self-help of community developers, this type of classic problem in development would be immediately self-corrected by the community. Not to mention all the additional features that the free developer community could produce for your own benefit.
I’m calling everyone to relay my request to snapmaker.
Thank you

1 Like

They did release some source:


Not sure if is JS or just 3D.

3D - it’s the Unity based application, not JS, which is developed using Electron.

1 Like

I’ve just installed the latest and it would seem I’m still having problems with the loopback address but not the image now, although the image does not import. Looking into the developer tools console link it takes me to line 289 underneath the loopback address tab index, line 289. Not sure if this helps but that’s what’s happening on my box. Win10 x64, latest build and patches.

From what I can tell, if 1) you save and set the laser power, and then 2) go to engrave with 2.4.1, the laser head just wanders off the platform. I then have to stop and reset everything.

hum now with 2.4.0 version When I try to upload I’ve got this message “Failed to parse image file”


still the same problem with /api/image
image



Good morning,

i´ve found another problem generating the gcode, snapmakerjs 2.4.0 running win10.

if i export gcode to file (a 3d-print) it normaly works.- but if i rename the file, then there is missing the “.gcode”

The code works if i add the .gcode.

2 Likes

Sounds like the way you rename the file is the problem. Does the original file have a .gcode suffix before you rename?

Doug

yes Sir! :wink:

it might be missunderstanding, in the window where i save the file, i just renamed the first 10characters not even the last 10, i just canceled the date in front of the name.

Edit: The issue is still in snapmakerjs 2.4.2

1 Like

Hi @xchrisd

… I have made the mistake of renaming and dropping the suffix and it was my fault.

Doug

When you click Export button, the popup window has an input with default file name, is the suffix “.gcode” missed from the default name? You might need to add that suffix manually…(at least in recent releases)

We’ve tested this on several Windows 10 machines but only some of them can reduplicate the issue, seems like it’s a system related issue. (We used the simplest way to download G-code file which is compatible with macOS, Windows and the browser so in File dialog the extension is not chosen. If the problem is too annoying we’ll find another way to workaround this)

1 Like

thanks. its no problem for me :wink:

i think the problem is the datatype which is not prechoosen.
if i edit the filename, no matter on which place (in front or rear) the prefix is gone.
i hope everyone understands me at this point.- it´s just a little bug.

Just installed the new version, opened a STL file, used custom settings and changed to “adhesion off”, slicing runs really fast but it hangs at rendering (around 50%), I wait and wait and program screen turns white resp. it is empty, but not frozen. I hit “reload”, a new empty screen appears and I have to load the STL file again. I tried a complete different STL object and it works.

The latter is a real small object, the first is a 25 hours print.

With the old Snapmaker3D V1.7.5 it works fine, takes longer to slice, but renders and generates G-code fine.

2 Likes

Thanks for you feedback! The G-code rendering uses lots of memory when slicing large model, we are solving the problem before we take down the old Snapmaker3D software.

1 Like

Hi @parachvte

Just tried v2.4.2 and incurred a problem with an SVG image. I tried this with a few different SVG images with the same result

I load the image, click on Preview (OK). click on Generate G-code (OK), click on Load (Not OK), Click on Export (Not OK)

Running the Windows 64 bit version of SnapmakerJS on my Windows 10 machines

The generated .nc file contains only one line
G0 X0 Y0

Doug

1 Like