Bug Reports and Feedback for Snapmakerjs V2.4.X


#156

Suggestions:
1.) Still Snapmakerjs does not update files by itself. If you loaded “xy.stl” to it then you change “xy.stl” with a CAD program and reload “xy.stl” to Snapmakejs it keeps the old file somehow in cache. It does not help loading “abc.stl” and then load “xy.stl” again. You have to restart Snapmakerjs to do a clean reload - or give “xy.stl” a different name.
2.) Exporting Gcode: I would like to have the suffix “.gcode” added automatically. Currently it creates a “filename.gcode”, but in case you delete the whole suggested name and type your own you have to add “.gcode” to it.


#157

I allready posted this to the developers.
It will be a long term project - other things are more important right now.

kind regards, Michael


#158

I allready posted this to the developers.

Thanks,

I like to add
3.) calculated print time in the GCODE generator is pretty accurate, but it’s totally off in the workspace area (double the time!)


#159

The estimated print time in the workspace is based on number of G-code lines executed:

E = {executed lines} / {total lines} * {time elapsed}, and yeah it’s not accurate.


#160

Rojal

any tips on how you determined an image was incompatible. I am working on a grayscale image right now and loading it into laser generator preview it looks fine but when I load it into the work space all I get is a black box. I tried the reset tip you posted above.


#161

Do you have the latest version v2.4.4-updated.1 ???


#162

I do I just downloaded and installed that a little while ago when I saw it was supposed to be resolved there which lead to it may be an issue with my image. I am trying to generate another one to test with as well


#163

New test file and what it looks like


#164

This is a normal behaviour. In the workspace the gcode is visualized.
Depending on th used algorithm you have small dots in the “white” spaces:
grafik.
Thick black lines are drawn if laser is on and in grayscale the laser power varies so this black sqare results.

I used the Atkinson algorith to show you the difference:

It should print just fine - if you are not sure make a very small test print on simple white paper.


#165

Thanks a bunch for the clarification. I will run it and see what the results are. Most of my stuff has been BW so far this is my first grayscale.

Thanks again


#166

“You could perhaps have the scale slider that supports a useful range and then still allow input of larger number in the text box.”

Yes, please. And non-uniform scale is occasionally useful. It would be nice to have as an option.


#167

I have the latest 2.4.4-updated.1 version installed, latest firmware, and I still cannot get greyscale prints with my images with my new 1600mW laser.


#168

Hello so I noticed a problem when uploading an image to greyscale. The picture orients the wrong way when I put it in the software. And the original picture is the right way.
here are pictures.

!


#169

Maybe you’ve imported it once - noticed the wrong direction - corrected that and tried to re-import.
This is not working because of the file Cache.
You have to restart Snapmakerjs to Import a new file with a allready used file Name (actual session).


#170

I think it’s because the orientation setting of image (on Windows), somehow the orientation is not read by Snapmakerjs? Please try saving the picture in portrait orientation in other image editor.


#171

Has the greyscale laser printing been fixed yet?

I have the latest 2.4.4-updated.1 version installed, latest firmware installed, and I still cannot get greyscale prints with my images with my new 1600mW laser.


#172

I don’t know if the laser cutter can do grayscale prints.
Did you have tried to reduce the dwell time?


#174

Yes, Im using very conservative settings. I don’'t recall right off had what I used but it was a significantly lower value that I would have normally used.

I sure hope you aren’t right on that. Would be very annoying and inconvenient to have to twitch lasers between printing and cutting.


#175

Hi all, I’m just starting with my Snapmaker and made some wonderfull things, but found the next problem Snapmakerjs is not working for other users that have not installed the app. I had to install one for me and one from my wife’s user to get it to work on each user.



#176

Just downloaded and installed Snapmaker 2.4.5. Why is everything in German now? The translation is - sorry to say that - very bad. even “Standard Terms used in 3d printing” are translated, such as “raft”, “brim” etc… and they are translated wrong. Please, can we have a language selector to set this back to English if we want? Thanks!!