Bug Reports and Feedback for Snapmakerjs V2.4.X


#137

just to confirm, Ubuntu 18.04, snapmaker 2.4.4. Laser engraving does not turns off with B&W, text works fine. Also, with B&W but loading png picture, the y axis did not worked properly.
I’ll try the virtual machine with 16.04 later.


#138

@rojaljelly @parachvte

Replying to myself - just a quick update:

First, - Thank you both for your help in getting snapmakerjs working so I can take full advantage of my SnapMaker. I don’t have or use Windows, I gave up on it back at WindowsXP.

Finally - Created a VirtualBox image of Ubuntu 18.04.1 LTS with just minimal applications, added application gconf2 (needed by snapmakerjs), added myself (in the virtual image) to the dialout group, extracted Snapmakerjs-2.4.4-updated.1-linux-x64.tar.gz to my home directory, and everything works without sudo. .stl & .svg imports, .gcode generation, and download & printing to the hardware. All is good. for anybody else that has run into this kind of problem here is a workaround until we can identify and fix the underlying problem.

PS - Found the Developers Tools under View and though I’m not much of a node.js programmer and I’m not familiar at all with the Developers Tools, I’ll try to figure out whats going wrong with my native Ubuntu installation when I get some free time. Thanks again.


#139

Please update to v2.4.4-updated.1, there’s a hotfix for B&W


#140

The application built on Electron for multi-platform compatible. For simplicity, we didn’t take time to organize the folders like install location (both Windows and Linux) or cache file folders right now (gonna think about it later).


#141

@parachvte

Snapmaker 2.4.4,Laser engraving generator G code is error.

Laser Off command M5 lose a space char, so laser never off.


#142

@WesleyHsu
Hi!

There is an updated version of the v2.4.4 online.

Please update the software.

BR, Michael


#143

@parachvte
I have made several attempts to get the laser to work with the update.1 version but it will not display after generate G-code , all I get is a blank white space, Is there some other patch that was to fix this issue.

ron


#144

Please upload your test file so I can check it.

I’ve used all modes (gray scale, b/w, vector and text) in v2.4.4-updateed.1 with the laser engraver and laser cutting module.


#145

owlSIDEleft
and svg
duck-silhouette-vector-free-scroll-saw-pattern|210x154
both a jpg and svg same results.
ron


#146

The original svg-file is not compatible with the current version of Snapmakerjs.
I Had to copy the path in the svg file with Inkscape into a new file (removed the link in the file too).
New svg version: Reimported.svg

Vector mode preview:

Vector mode Workspace:

B/W mode preview:

B/W mode workspace:

I stopped the b/w print becaue it would take about half an hour to finish.
Just want to show the results too:


#147

Ok Then there is some thing wrong in my system then as in the work space view there are no grid lines and no image just white.


#148

Do you have the must actual version v2.4.4-updated.1 ?


#149

Yes I even reloaded it today again.


#150

@rojaljellyI
tried to run with the window 32bit version v2.4.4-updated.1,this time instead of 64bit, same results white work-space, i did see something spin for a brief second, but white.


#151

You can try resetting the software (new install doesn’t do this):

If this doesn’t help at all I don’t know what you can do but wait for an official reply.


#152

That made it work!!! you are amazing, now will try it with 64 bit, thanks much for your help.
ron


#153

@rojaljelly
Ok now when reload 64bit it works great, work-space shows up just fine. All is right with the world again.
ron


#154

Well @rojaljelly
It works with jpg BW images but not vector, like the duck one. I get the grid pattern but no image in the workspace, just a dot with the name of the g-code file that was generated.


#155

The original svg doesn’t work. Download and try my version.


#156

Suggestions:
1.) Still Snapmakerjs does not update files by itself. If you loaded “xy.stl” to it then you change “xy.stl” with a CAD program and reload “xy.stl” to Snapmakejs it keeps the old file somehow in cache. It does not help loading “abc.stl” and then load “xy.stl” again. You have to restart Snapmakerjs to do a clean reload - or give “xy.stl” a different name.
2.) Exporting Gcode: I would like to have the suffix “.gcode” added automatically. Currently it creates a “filename.gcode”, but in case you delete the whole suggested name and type your own you have to add “.gcode” to it.