Bug Reports and Feedback for Snapmakerjs V2.4.X


#99

@virtualritz The image generated by ContextFreeArt uses <use> tags a lot, and the tag is not supported yet by Snapmakerjs. A workaround is to replace <use> tags to its definition, or you can wait for our updates on SVG parsing improvement.


#100

Snapmakerjs appears to use a lot more memory than Snapmaker3D did to do the same thing. Just loading a model in and trying to generate G-Code causes it to crash on my computer as it runs out of memory. Snapmaker3D v1.7.5 still works fine, but it’s worrying to think I’m stuck there as you move forward. :frowning:


#101

Hey Folks,
can we please have all the functionality whis so important that Snapmaker cannot be operated without ALSO IN SNAPMAKERJS? I am thinking About

  • calibration
  • Change Filament

    I am having a hard time currently because my touchscreen is broken and I can’t operate my Snapmaker anymore. Would be really great if we could have some redundancy here.

Thanks!


#102

@e-maddin
We are working on migrate calibration function now. The calibration function used on the screen uses its own protocol to communicate with the firmware, but the protocol can not apply as well to Snapmakerjs. Modifications on firmware are needed and then we can implement the functionalities on the software. (Hope we can have it done next month)


#103

Hi, I noticed on laser engraving, take image it prints only lines. Image is not engraved. Can you check this at the earliest and resolve. Or is it something that i am missing. I tried with v2.4.2 and prints good.


#104

For those who downloaded v2.4.4 before [Aug 16, 2018 5:39:22 PM GMT+0800], and found that in the CNC tab the image didn’t show up at all (but the G-code generated is ok), pls re-download and reinstall the app. There is a hotfix for it but for convenience the version tag remains the same. (The bug only effects the first few ppl downloaded Snapmakerjs yesterday)

Update: Snapmakerjs v2.4.4-update.1 released.
Fixed a laser B&W engraving issue that missing newline (\n) followed by M5 commands. (Thanks for reporting @venuasg @Nina @rojaljelly)

Please checkout the updates on Downloads and Updates


#105

Still engrave bug is not fixed, it does not print the design, it prints straight lines all the time. Request to look into it.


#106

@venuasg
Can you provide the file you want to engrave and tell me something about your settings?
I’m not sure if I can help but I want to see the the problem you have.

Here a picture of my test print on wood (grayscale marked):

Test file:

Settings:


#107

I have the same issue with laser B&W .Only makes lines. :slight_smile:


#108

Same here 2.4.4 - BW Laser engraving generates faulty gcode. The code generated is only 1/4 of the working code with the older version.

With 2.4.3 it works fine.


#109

@parachvte
I can confirm the B/W-mode is not working correctly in 2.4.4.
Preview looks fine but the laser is on all the time.
Please have a look at it.


#110

Such a silly question, but… where is the connection button? I let v2.4.4 generate the G-Code and uploaded it to the workspace. But no button to connect Snapmaker, the Play button is inactive. In 3D section I got “Material & Support”, “Printing Settings” and “Output” with just Load Gcode to workspace and Export Gcode to file. In the corresponding window there is just “rotate”, “scale” and “move” In the “X,Y,Z” window just “Axis” and “Gcode”.

No way to connect, even the gears icon don’t lead me to the Snapmaker. Currently I use Snapmaker3D parallel as backup solution.


#111

John here,
I live in the U.S so I use inches. Whenever I am designing something in fusion 360 I use inches, so whenever I export it into snapmakerjs to print, it makes the product very small because it thinks its mm.


#112

Welcome to the rest of the world!

Some slicers can do the transformation automatically.
1 inch = 25,4 mm so you have to scale by 2540%.
Maybe the developers can include a function in the next versions so you can still use the scale function without calculating if you want to print at 80% of the actual size or so.

Another way is before you export the STL-file from Fusion 360 change the unit to mm.
The exported file would have the right size in mm.
grafik


#113

@arno.nymberg

I think you collapsed it. Please try this:


#114

yes, I missed this one, but when I slide it out, the expanded right window is still empty. The old Snapmaker3D I currently use gets connection to the Snapmaker printer easily, so driver or connection must be fine.


#115

@arno.nymberg
I think you’ve manually removed it and you are right - I also don’t know how to restore single widgeds which had been removed. But you can restore the defaults:

PS: Ich habe gesehen, dass Du eine deutsche Oberfläche eingestellt hast - also gerne auch Kommunikation unter uns auf Deutsch (bin aus Österreich)…


#116

Thanks! That’s it, back to standard and everthing is where it belongs! I am pretty sure I didn’t mess up the layout, it was just a clean install, however it was an install “over” a previous version, perhaps that messed up the setting. As I thought layout already was standard this doesn’t came to my mind at all.

privat stuff:
Danke für das Angebot, ich bleib bei englisch, damit Problem / Lösung für alle verständlich bleibt. Schöne Grüße nach Österreich!


#117

Thank you so much!! Now it works perfectly and I am able to print many buttons at a time now that the size is fixed!! :star_struck:


#118

Hi @Rainie

Good development standards do NOT allow for the distribution of software with the the same V.R.M level with a text suffix. You shipped 2.4.4 Beta and then 2.4.4 Update The latter should have been 2.4.5, it is less confusing for all.

Have a great week

Doug